Announcement

Collapse
No announcement yet.

Lost power and cut off.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • sportakaplis
    started a topic Lost power and cut off.

    Lost power and cut off.

    the problem is. when you driving check engine light came on and car lost the power for couple of seconds, but after that car drives like nothing happened and engine light was gone. but sometimes engine ligt come on and car yust cut off. then turn the key of and can start the car like nothing hapened before. please help
    smart fortwo 2005 0.7 450model

  • sportakaplis
    commented on 's reply
    i newer had to wit. can start up strait after its cut off

  • heinkeljb
    replied
    When the CPS went on my 1999 450 it did NOT produce any error code stored or otherwise. I had a STAR unit connected at a time when the car died on me. So unfortunately all these electronics that are supposed to help by logging an error code don't always work as they are supposed to.

    John

    Leave a comment:


  • Mr T
    replied
    Normally you'll get an error code stored if the crankshaft rotation sensor is playing up.
    When mine failed, it would be fine until the engine was warm & then would cut out at tick-over, normally as you pulled up at a junction. Sometimes it would restart straight away, other times I had to wait 5 mins. I had a code stored P0336 i think. I changed the sensor & it's been fine since.

    Leave a comment:


  • tolsen
    replied
    Yes same sensor. TDC, engine speed, crankshaft rotation etc.
    Mine (a 450 Cdi) had a single hiccup similar to yours many years ago in 2002. I never figured out what had caused it but the problem never returned.
    At least if problem keeps reoccurring there is a chance you may get to the bottom of it and sort it out.

    Leave a comment:


  • sportakaplis
    replied
    do you mean Crankshaft position sensor (sensor sits on the top of the bell housing to calculate the position of the crankshaft, it reads engine speed and allows the management system to change injector openings with changes in engine rpm) this ine is already changed

    Leave a comment:


  • tolsen
    replied
    In that case could be engine speed sensor.

    Leave a comment:


  • sportakaplis
    replied
    when you start the car again, the EML is gone already. and sometimes is on about 4 seconds when car is losing power, but it's not enuf time to diagnose the problem.computer does not show any fault. already tried.

    Leave a comment:


  • 137699
    replied
    Get it hooked up to STAR and read the fault codes.
    Without codes it's pure guesswork and could be any one of a hundred or more reasons.

    Leave a comment:

Ad Widget

Collapse
Working...
X