Announcement

Collapse
No announcement yet.

Engine cutting out when I pull out at junctions

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Engine cutting out when I pull out at junctions

    Hello!

    I have a 2009 smart fortwo which I've owned 5 years with no problem at all (bar my husband getting slightly squished in a Mercedes sandwich in the snow - thank god those panels are plastic!) that has recently decided to try and send me to an early grave by scaring the bejeezus out of me at random intervals.

    the first time it happened, I was on my way home, on what was only a 5 minute journey and as I pulled out at a junction, it just suddenly cut out completely. Luckily, there was enough momentum so get round the corner and then I managed to push it up onto the curb and out of the way. the engine light came on and when I turned the key part way, the fans/engine light etc came back on, but when I turned it the whole way, everything cut out again and it wouldn't restart or do ANYTHING - no noise of the engine trying to start or turn over and all the fans etc cut out again. I called my recovery service who arrived about 45 minutes later and of course, it started no problems for him. we took it to a garage, who ran diagnostics on it, but couldn't find any problem at all. It has since run perfectly for another month. Until yesterday.

    This time, I had been driving for 20/25 minutes when I went to pull out at a junction. exactly the same thing happened, where it started pulling away fine and then suddenly (midway through turning the corner) cut and I had to coast it until I could reach a safe place to pull it over/off the road. Again, it wouldn't restart (although the hazard lights did stay on). after about 15 minutes, I tried again and it did restart this time - I turned off start/stop (it had definitely gone into eco mode and stopped the engine at the junction this time, but I can't remember if I had been driving for long enough at the time of the 1st incident for eco mode to have switched on) and was basically terrified every time I had to fully stop before pulling away again for the remaining 30 minutes of driving, but I did get home safely and without further issue.

    any ideas what might have caused this? the garage obviously want us to take it back in, but I'm reticent to pay another 70 for them to run another diagnostic test that will probably not turn up anything again and would like some specific ideas of what to ask them to look at.

    thanks in advance!

Ad Widget

Collapse
Working...
X